Recent Posts

Pages: [1] 2 3 ... 10
1
General Help / Updated chipset for Windows 10
« Last post by andrewwe on May 24, 2021, 08:11:44 PM »
Updated Chip] VHS to Digital DVD Converter Adapter for Win 10, Video Audio Capture Card Grabber Recorder Device Support Windows 10 8 7 XP VISTA PC Convert Analog Video to Digital Format (black)

https://smile.amazon.co.uk/gp/product/B07MCTQRSP/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 - curently 9

2021 version - works for me.. 
2
General Help / My 2861 driver
« Last post by andrewwe on June 18, 2020, 06:45:56 PM »
Ever since my Windows Pro version has updated to:

Windows 10 Pro
Version 1909
OS build 18363.900

my Ezcap 116 Video Grabber usb is shown as unrecognised:

Unknown USB device (Port reset failed) Windows has stopped this device because it has reported problems (code 43).

I am now unable to use my Debut app.

Will you be updating the driver, please?
3
General Help / Lost disc and license key for ezcap 116
« Last post by mazo on May 26, 2020, 06:01:46 PM »
Hi,

I purchased my ezcap back in 2010, and got busy with life and never finished transferring my videos. I'd like to start again, but now obviously have a newer pc, and I not longer have the disc. I can download the software, but it's asking for a license key. If you've already purchased the product, why so much red tape to use it? Does the software work for other screen capture hardware? Better yet, does anyone  know of free software I can use with my ezcap 116?
4
EzCAP vhs/camcorder to dvd / Re: Where can I get the latest windows 10 driver
« Last post by smalltown on August 10, 2019, 05:42:02 PM »
Well I found a newer version I think it was 3.5 on a posting here on Ezcap. I was finally able to get video, but only using VLC. To get audio I ran my audio directly to my desktop audio in. Still trying to find out how to actually record to my PC using the VLC program, but I am getting there.
5
EzCAP vhs/camcorder to dvd / Re: Where can I get the latest windows 10 driver
« Last post by smalltown on August 09, 2019, 02:04:34 PM »
The current EasyCap capture disc that I have is Version 2.1C  I'm hoping someone could post a link to a newer version so I could try to get this EasyCap going for Win 10 64 bit.
6
EzCAP vhs/camcorder to dvd / Where can I get the latest windows 10 driver
« Last post by smalltown on August 08, 2019, 01:36:40 AM »
Trying to use my ezcap tv after some time. In the past it worked with prior windows versions.
I am now running Windows 10 64 bit version 1903, OS build 18362.267
I have no audio or video.
Trying to connect an older VCR to copy some old tapes to my PC.
I did verify that the VCR is working, and outputting video to a TV via the TV RCA video input connector.

I did download http://www.ezcap.tv/WDM_Media_D020412_EMPAudio.exe after reading an older post, but that seemed to make things worse.  Before I was seeing in device manager under usb listings a composite device, but that disappeared with the downloaded link. I have not seen any listing under imaging devices.

Any help would be appreciated.
7
General Help / Have sound, no video in preview, but captures both?
« Last post by teacupsmom on June 24, 2019, 12:01:58 AM »
So I can hear audio in the preview, can't see a video preview.  I can capture, but I can't see what I have captured until I stop capture and go to the file.  Is there something I need to do to fix this?  I have Windows 10, and RCA cable securely attached
8
General Help / transfer to flashdrive
« Last post by Jacidm4 on January 02, 2019, 08:46:42 PM »
Can anyone tell me how to transfer my videos to a flashdrive? Every dvd I burn does not work, in multiple different dvd players, and different brands of disks, even Verbatim disks do not work anywhere but the computer they were burned on. I would really like to share this old movies with my family, just don't know how?
9
General Help / Re: Windows 7 Ezcap Drivers and Lost Showbiz Key?
« Last post by Jon-Toft on October 31, 2018, 09:18:37 AM »
Hi, I have the same problem! Lost the activation code.
Thanks in advance :)
10
EzCAP vhs/camcorder to dvd / EXCAP.TV 116 drivers for Mac OS X 10.13.6
« Last post by egrabczewski on October 23, 2018, 11:32:03 AM »
I've upgraded to Mac OS X 10.13.6 and downloaded tried installing VideoGlide 1.5.5 (as supplied previously) but it fails at the end. I tried downloading VideoGlide 1.5.5.2 which appears to install but when I run it (following reboot) I get the error message "There are no available digitizers...". Can anyone help?
Pages: [1] 2 3 ... 10